[arch-dev-public] Status of QT4

Pierre Schmitz pierre at archlinux.de
Thu Oct 18 04:05:40 EDT 2007


I just wanted to ask what the status of QT4 is. There are some packages which 
cannot be updated due to dependency on the new version of QT.

It wouldn't be that bad idea to update qt before KDE4 is ready. I wonder if 
the following upgrade path works:

* introduce a qt3 package (just rename the current qt; files should stay
  in /opt/qt)
* repackage those packages which directly depend on qt3. (there are not that
* update the qt package to version 4 and install all files to /usr
* packages like kdebase should still work because they do not directly depend   
  on qt (from pacmans point of view) and search fore qt files in /opt/qt.

What do you think? Is it really that simple?


More information about the arch-dev-public mailing list