[arch-dev-public] xorg move to extra?

Xavier shiningxc at gmail.com
Wed Oct 15 08:47:53 EDT 2008

On Wed, Oct 15, 2008 at 7:38 AM, Pierre Schmitz <pierre at archlinux.de> wrote:
> Am Mittwoch 15 Oktober 2008 01:33:33 schrieb James Rayner:
>> It'd be a good idea to set conflicts=() with the older nvidia/catalyst
>> so that their xorg doesnt get upgraded, and thus their X isn't broken.
>> That way we don't piss off a lot of people.
> Maybe not a bad idea. But I would add a depends('xorg-server<1.5') to those
> drivers. And if some day those drivers work again we just have to update
> those.

You can use versioned conflicts, so you would not have to update the
xorg-server package when a driver works again, because it will very
likely be a newer version of it. But then it is not clear when it is
safe to remove these conflict lines in xorg-server.
So I agree that the depends way still looks nicer.

More information about the arch-dev-public mailing list