[arch-dev-public] Vim breakage...again

Aaron Griffin aaronmgriffin at gmail.com
Wed Jul 22 20:19:21 EDT 2009

On Wed, Jul 22, 2009 at 4:58 PM, Dan McGee<dpmcgee at gmail.com> wrote:
> What the heck is going on?
> I spent a good hour or two rebuilding the vim plugins for the correct
> location when vim first went into [testing] a few months ago, and with
> this new vim in testing, they are once again *all* broken. This is
> unacceptable as far as I am concerned. If I'm the only one that thinks
> so, I'll quiet down a bit, but I am getting awfully frustrated with
> this.
> If we move plugin locations or distro install locations, *all*
> packages dependent on this location need to be rebuilt. I even made it
> 10 times easier to do so by putting the path in a shell script
> variable!
> -Dan
> dmcgee at galway /etc
> $ pacman -Sl testing | grep 'vim-'
> testing vim-a 2.18-3
> testing vim-bufexplorer 7.2.2-2
> testing vim-buftabs 0.13-1
> testing vim-colorsamplerpack 6.0-2
> testing vim-doxygentoolkit 0.2.4-1
> testing vim-guicolorscheme 1.2-1
> testing vim-matchit 1.13.2-1
> testing vim-minibufexpl 6.3.2-5
> testing vim-omnicppcomplete 0.4.1-2
> testing vim-project 1.4.1-3
> testing vim-taglist 45-2
> testing vim-vcscommand 29-2
> testing vim-workspace 1.0b1-3

Good catch - I wasn't aware of this, as I keep my plugins in my home
dir these days.

Next time the vim plugin path changes, can we make sure to rebuild all
plugins as well? If help is needed, send an email to the list.

More information about the arch-dev-public mailing list