[arch-general] alsamixer doesn't work.

Jackson Robertson daedalusman at gmail.com
Sun Dec 9 04:56:43 EST 2007

Ah, I see what was wrong. I at one point had installed and configured
pulseaudio and alsa to use pulse, but have since uninstalled pulseaudio and
still had alsa configured to use pulse. This led to the message and now can
use my keyboard to adjust sound once again. Thanks for helping me see the


On Dec 9, 2007 1:41 AM, Eric Belanger <belanger at astro.umontreal.ca> wrote:

> On Sun, 9 Dec 2007, Jackson Robertson wrote:
> > Hi list,
> >
> > I have had this problem for a little while now and haven't been able to
> find
> > a solution. When I run alsamixer in console I'm getting this error...
> > "ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library
> > /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
> >
> > alsamixer: function snd_ctl_open failed for default: No such file or
> > directory"
> > After checking the arch wiki, it said to try and reinstall the kernel,
> I've
> > tried this and it had no effect on the problem. This problem leads to me
> not
> > being able to use keytouch as keytouch uses amixer to change the volume
> and
> > amixer uses alsa, so I just get a bunch of errors when I use keytouch.
> Does
> > anybody on the list have any ideas on this? Thanks for the help.
> >
> > Jackson
> >
> >
> The /usr/lib/alsa-lib/libasound_module_ctl_pulse.so library is in the
> alsa-plugins package for community. I guess you have it installed and
> want to use it, right?
> To use that library, you need to have pulseaudio installed. Is it
> installed and setup correctly?  Did you logout and relogged in after
> adding your user to the pulse group?
> Eric
> --
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://archlinux.org/pipermail/arch-general/attachments/20071209/2d427e28/attachment.htm>

More information about the arch-general mailing list