[arch-general] latest updates broke kde3, kde4, twm & console login ability

David C. Rankin drankinatty at suddenlinkmail.com
Sat Jul 18 01:21:06 EDT 2009

On Tuesday 14 July 2009 03:06:04 am Rafa Griman wrote:
> Hi :)
> On Tuesday 14 July 2009 09:43:24 David C. Rankin wrote:
> > Listmates,
> >
> > 	Here is a rather strange one. On a dell gx280 box (Intel graphics) that
> > had been running both kdemod3 and kde4.3 beta 2 just brilliantly, I am now
> > left without any way to log in from the console. All was great until
> > updates earlier today.
> >
> > 	What happens is -- the box boot fine and will bring up the kdm
> > login/chooser display just fine. If kdm (from testing) is being used, then
> > after supplying your user/pass all appears like it is going to start as
> > usual. The Air theme is presented and the first little icon (I think it is
> > a hard drive) fades in like usual. Then all of a sudden <BOOM> &%$ {BAM}
> > !#$ <CRASH!!>, the screen goes black flickers slightly and then kdm
> > restarts. (you could do this over-and-over all night)
> Had this same problem once and solved it deleting the plasma config files in 
> ~/.kde. You can also try creating a new user and logging in with this new 
> account to see if it works.
> > 	The weird thing is that you CANNOT even choose "console login" to drop to
> > text mode. Pretty much the same sequence plays out here to. After supplying
> > your user/pass all appears like it is going to drop you to the text
> > console, then the screen goes black and kdm restarts and you are left right
> > back where you started -- Huh??
> >
> > 	Another bit of weirdness. When I edit my gurb config to tell it to just
> > start in runlevel3 be adding a "3" at the end of the boot like, the boot
> > process seems to ignore this. You see the "Entering Runlevel 3" line go by
> > during boot, but then <WHACK> kdm starts and you are back at the beginning
> > of the loop staring at the kdm greeter knowing this trick isn't going to
> > work (Kinda reminds me of Groundhod Day -- the movie -- you remember)
> Maybe you've added kdm to your DAEMONS line in /etc.rc.conf ;) Remove the kdm 
> part in the DAEMONS line.
> > 	So I have tried a pacman -Syu and loaded another 30 meg of packages, but
> > none looking like they would solve the problem (and they didn't)
> >
> > 	Now I'm kinda at a loss What gives? What to check? But, how do I recover?
> > (I still have full ssh access to the box, so fixing it won't be a problem
> > once I can figure out what I'm looking for and how to fix it. Any help
> > would be greatly appreciate it.
> I'm also having issues with my intel gfx card on 3 laptops (Dell Latitude 
> D610, MSI Wind and Acer ONE netbooks). When you hit Ctrl+Alt+F1 you get a VT 
> but when you hit Alt+F7 you don't get the X (KDE 4.2 stable in my case) 
> session back. This happens on all 3 laptops with Intel gfx card and latest 
> updates :(
> EXA acceleration, no UXA (can't get it to work properly: when you log out from 
> KDE 4.2 stable it just hangs there with a black screen without fully logging 
> out).
>    Rafa


	I am just starting to work on this problem again. The box still will not start kde4 or drop to a console login with "kdm" as the greeter. I can load twm and openbox. With kdm3, I can also load kdemod3, but no kde4.

	In openbox, I can load kde4 konqueror and other applications, but not kde4/konsole. When I try to start kde4/konsole I get:

/usr/bin/konsole: error while loading shared libraries: libphonon.so.4: cannot open shared object file: No such file or directory

	Does this look related??

	The problem seems to have started on the 14th. The only other interesting log entries are:

Jul 14 02:18:09 supersff kdm[2093]: Can't create/lock pid file /var/run/kdm.pid
Jul 14 02:20:43 supersff kdm[2124]: X server for display :0 terminated unexpectedly

	I don't think this is part of the problem, but actually the result of my switching greeters with /etc/rc.d/kdm stop && /etc/rc.d/kdm3 start (I think). Other than the 14th, the messages isn't repeated in the logs. The only other kdm related messages are:

Cannot load /usr/share/apps/kdm/faces/.default.face: No such file or directory

	but those have been repeated for quite some time. I have re-downloaded & installed kdebase-workspace and also created a brand-new user and tried to start kde4 -- same crash. I don't have kdm in my DAEMONS line any longer and I have configured kdm to start from /etc/inittab:

00:10 supersff:~> grep 5 /etc/inittab 
x:5:respawn:/usr/bin/kdm -nodaemon

00:10 supersff:~> grep DAEMONS /etc/rc.conf
DAEMONS=(syslog-ng network hal @netfs @ntpd @sshd @crond @avahi-daemon @mysqld !postfix !dovecot !httpd @samba @cups)

	This is definitely kde4 4.2.96 and kdm related. KDE4 worked fine from the time I first installed it up to the latest update. kdemod3, twm, openbox, etc.. all still work fine, just not kde4. That's why I don't think it is intel graphics related. I don't even have an xorg.conf, so X is just using the defaults (nothing for me to mess up:-)

	Does anybody have any more pointers? Any additional info to look at or tests to try? It would sure be nice to get this one fixed. That way I could go back to writing kde4 bug reports ;-)

David C. Rankin, J.D.,P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339

More information about the arch-general mailing list