[arch-general] did my 4/10/10:pacman -Syu: destabilized e17's run command dialog??

Joe(theWordy)Philbrook jtwdyp at ttlc.net
Sun Apr 18 16:44:43 EDT 2010

It would appear that on Apr 17, David C. Rankin did say:

> On 04/16/2010 04:12 PM, Joe(theWordy)Philbrook wrote:
> > 
> <snip>
> > How can I a regular "Joe user", figure out if this is an actual E17 bug
> > or if it's an Arch specific thing???
> > 
> Joe,
> 	I'll have to check my E17 install on Arch, but I just got through going through
> fits with E17 on suse. All of a sudden, E17 virtual desktop management and the
> pager went nuts. If I opened an app on desktop 1 and then switched to desktop 2,
> etc.. the open app was visible on on desktops. (like you had the window set as
> sticky to show up on all desktops)
> 	Further, E17 would crash every time I tried to change shelf properties or
> add/remove apps from ibar, etc.. The issues ended up being something in my ~/.e
> directory. I hadn't changed any settings at all in E17 for quite some time, so
> one of the E17 updates did something strange to the config that really screwed
> E17 up. Wiping out my ~/.e directory and restarting with the default black &
> white theme cured it. After the restart and forced rebuild of the default
> configuration, I could reconfigure E17 exactly the way I had it before and it
> worked just fine. If you haven't tried it, it might be worth a shot.

Thanks for looking into it David, And for the suggestion.  I suppose it
could be that something messed with something in my ~/.e file hierarchy
That's probably more likely than that something changed in such a way as to
make some formerly viable set up to suddenly become incompatible...

I really hope that if either is true, it's the former as I really detest
rebuilding my keyboard shortcuts with the freaking pointNclick GUI config
tool. Especially since there isn't a one that matches the default settings
AND my mouse skills are a negative value... {Gawd how I miss the old
scriptable pre-dbus enlightenment_remote command. that allowed me to set
*_MY_* default keybindings with a bash script as the first thing to do once
e17 was installed}

At least (if the former is the case) I can use the fact that when I first
got it set up the way I liked I did a "cp -R ~/.e ~/tmp/e_bu" (Something
I learned to do because with some of my e17 installations the "remember"
settings for a few things in my .xintrc kept getting "lost"... 
{PCLinuxOS comes to mind where I've actually gone so far as to put an
"cp -R" in my .bash_profile to restore the original every time I login...})

I'll have to test if restoring the prev version of .e will fix it. After
all the only thing I'd lose is the updated keybinding assigning Alt+F2 to
xfrun4 instead of the e17 run prompt... Then I suppose (given I can still
restore the .e dir if it doesn't help) I could let e17 build me a new
default .e ... I'll let you know how it pans out in a day or two.

|   ~^~   ~^~
|   <*>   <*>       Joe (theWordy) Philbrook
|       ^                J(tWdy)P
|     \___/         <<jtwdyp at ttlc.net>>

More information about the arch-general mailing list