[arch-general] Do packages built on libusb need rebuilding on libusbx? upsd won't stay connected over usb.

slubman lists at slubman.info
Sat Jun 9 20:37:02 EDT 2012

On 10 juin 2012, at 02:27, David C. Rankin wrote:

> On 06/09/2012 08:41 AM, Kevin Chadwick wrote:
>> The question would be, doest that pose a greater security risk.
>> Have you tried using -u nut.
>> If that fails I'd use systrace (strace on Linux) or something to see why
>> it fails.
> Thanks Kevin,
>  Yes, I tried '-u nut' and it fails the same as no '-u user' at all. All of
> this looks like some file permission on some device or something changed, but
> every file/device I look at, the permissions are the same between
> working/non-working box. I'll have to go try and dust off my debugging
> capabilities. If you think of anything else, let me know :)
> -- 
> David C. Rankin, J.D.,P.E.

Have you looked to the usb device permission?

After the latest upgrade I did (kernel, libusbx, systems-tools and a lot of other stuffs), upsd wouldn’t connect.

But as described on the AUR page, the package must be recompiled, with an addition to the configure command to put the udev rules in the correct directory.

Cf. http://aur.archlinux.org/packages.php?ID=5379

Best regards.

Nicolas D (a.k.a slubman)

More information about the arch-general mailing list