[arch-general] Failed to give slave programs access to the display

Leonidas Spyropoulos artafinde at gmail.com
Sun Feb 10 08:57:47 EST 2013

Hi all,

I have a strange problem with my GDM. The problem started when I got a
new monitor combined with updates.

First I got a new monitor and connected (switching from DVI -> VGA
cable to DVI -> DVI cable). It was different resolution as well
1900x1200. At the same session (ans without restarting) I upgraded
after a week or something with the new kernel 3.7.6-1-ARCH and latest
nvidia drivers 313.18.3-3. After that point the gdm starts (but slower
than before) and as soon as I put my password and tried to start my
session, the background image is lost (turns to black) I see some
flickering and the Gnome-shell session loads but I can't access
anything. I had this problem before randomly so I didn't pay attention
but now it's consistent. I can move the mouse around without affecting
the Gnome-shell though.

journalctl [1] shows the above message along with NVRM errors right
after I login.

I tried downgrading to lower kernel and nvidia drivers but it didn't
help as I cannot load the nvidia driver when I downgrade (I think I
need to rebuild the nvidia kernel module and don't know how).

I tried deleting the .config, .gconf, gnome2, gnome2-private, .nv
folders from my home folder in case it was configuration but nothing.

Anyone have some suggestion?

[1]: https://gist.github.com/spyropoulosl/2c0710f4c75eba029399
Caution: breathing may be hazardous to your health.

#include <stdio.h>
int main(){printf("%s","\x4c\x65\x6f\x6e\x69\x64\x61\x73");}

More information about the arch-general mailing list