[arch-general] UEFI madness

Mike Cloaked mike.cloaked at gmail.com
Sat Mar 2 05:32:40 EST 2013

On Sat, Mar 2, 2013 at 6:44 AM, David Benfell <benfell at parts-unknown.org>wrote:

> Hash: SHA1
> Hi all,
> So far, my attempt to install Arch Linux on a UEFI system is a total
> facepalm moment. The problem is in booting post-install.
> So, first, does anyone have actual--and successful--experience
> installing Arch on a UEFI system? Yes, I went to the Arch Wiki, which
> initially pointed me at GummiBoot. There are actually two sets of
> instructions, one given where I looked first, for the UEFI entry, and
> another under the entry for GummiBoot. Neither succeeds, but I wound up
> following the latter set of instructions (and cleaning up extra entries
> with efibootmgr, which fortunately makes this relatively easy).
> GummiBoot says it can't find /vmlinuz-linux. I tried modifying the
> configuration to say /boot/vmlinuz-linux, but no joy. Apparently, I'm
> really supposed to copy this file and the initrd image to the EFI
> partition, but nobody says where in the EFI partition, so I have no idea.
> I also tried following the instructions for grub-efi. I'm just
> mystified. I managed to install the right package, but from there I just
> wasn't understanding a thing. I've been using linux since 1999 so this
> shouldn't be so completely mystifying.
> I tried installing rEFInd (from sourceforge). As near as I can tell, it
> does indeed detect all the possible boot options on the system. But when
> I try booting the Arch installation, it says it can't find the root
> partition. It also detects the GummiBoot option, but that leads the same
> place as before. Finally, it detects the Windows option, which I hope
> still works (unfortunately I do need this).
> I guess getting something that just works--like it did with BIOS
> systems--is not in the cards. What do I do now?
> Thanks!
> I have a system that I installed a couple of weeks ago using rEFInd -
which works really beautifully and needs no manual intervention when new
kernels arrive.  However it did take me some time with a lot of help from
Rod Smith to get it all set up correctly.

Basic steps were:
1) Format disks with GPT instead of MSDOS
2) Make sure that there is a /boot/efi/EFI ESP which is formatted FAT32
3) Since I also wanted /boot to contain initial ramdisk and kernel I had
/boot as a directory in my root (/) partition which is ext4.
4) In order to get it to work I made sure that the rEFInd config files were
set up in the ESP as well as the required files in /boot (and including the
ext4 rEFInd driver files in the ESP so that rEFInd can read the initrd and
kernel files unde ext4 in /boot (and include the rEFInd driver files in
those directories also.
5) In my system I found that the standard method to write the nvram entries
failed to work - so I had to boot to the efi shell from the arch install
iso on usbkey and write the nvram entries from the shell.

If you want more details I can post more tomorrow.

I hope this helps.

mike c

More information about the arch-general mailing list