[arch-general] Realtek wifi won't come up

Jameson imntreal at gmail.com
Tue Mar 12 11:45:29 EDT 2013

On Fri, Mar 8, 2013 at 8:51 PM, M0r S <m0rtiferrimus at gmail.com> wrote:
> Hey everyone,
> I'm trying to install Arch. The first time I tried installing everything
> worked fine, even the wifi, which usually doesn't work with linux. However,
> my laptop battery died in the middle of downloading packages because I was
> careless and hadn't plugged it in.
> Now, when I enter "ip link set wlp2s0f0 up", it doesn't set the interface
> up. Strangely, when I reboot, the interface is renamed to wlan0 (that's
> what it was when the wifi worked), even though the wiki says it shouldn't.
> Running "modprobe -r rtl8192ce && modprobe rtl8192ce" changes the interface
> name to wlp2s0f0. "ip link" gives me (besides the lo interface)
> 3: wlp2s0f0: <BROADCAST, MULTICAST> mtu 1500 qdisc nook state DOWN mode
> DEFAULT qlen 1000 link/ether 00:e0:4c:81:92:53 brd ff:ff:ff:ff:ff:ff
> Before, it gave me:
> 2: wlan0: <NO-CARRIER, BROADCAST, MULTICAST, UP> mtu 1500 qdisc mq state
> DOWN mode DEFAULT qlen 1000 link/ether 24:ec:99:4c:60:1f brd
> ff:ff:ff:ff:ff:ff
> What else can I try? Lspci and dmesg show that the firmware has been loaded
> and that the card has been recognized.

The first thing I would try would be to move
/etc/udev/rules.d/network_persistent.rules to root's home directory,
and reboot.  That way you should wind up with the wlp2s0f0 name
whether it's working or not, otherwise.


More information about the arch-general mailing list