[arch-general] Realtek wifi won't come up

M0r S m0rtiferrimus at gmail.com
Thu Mar 14 17:08:40 EDT 2013

On Tuesday, March 12, 2013, M0r S <m0rtiferrimus at gmail.com> wrote:
> On Tuesday, March 12, 2013, Jameson <imntreal at gmail.com> wrote:
>> On Fri, Mar 8, 2013 at 8:51 PM, M0r S <m0rtiferrimus at gmail.com> wrote:
>>> Hey everyone,
>>> I'm trying to install Arch. The first time I tried installing everything
>>> worked fine, even the wifi, which usually doesn't work with linux.
>>> my laptop battery died in the middle of downloading packages because I
>>> careless and hadn't plugged it in.
>>> Now, when I enter "ip link set wlp2s0f0 up", it doesn't set the
>>> up. Strangely, when I reboot, the interface is renamed to wlan0 (that's
>>> what it was when the wifi worked), even though the wiki says it
>>> Running "modprobe -r rtl8192ce && modprobe rtl8192ce" changes the
>>> name to wlp2s0f0. "ip link" gives me (besides the lo interface)
>>> 3: wlp2s0f0: <BROADCAST, MULTICAST> mtu 1500 qdisc nook state DOWN mode
>>> DEFAULT qlen 1000 link/ether 00:e0:4c:81:92:53 brd ff:ff:ff:ff:ff:ff
>>> Before, it gave me:
>>> 2: wlan0: <NO-CARRIER, BROADCAST, MULTICAST, UP> mtu 1500 qdisc mq state
>>> DOWN mode DEFAULT qlen 1000 link/ether 24:ec:99:4c:60:1f brd
>>> ff:ff:ff:ff:ff:ff
>>> What else can I try? Lspci and dmesg show that the firmware has been
>>> and that the card has been recognized.
>> The first thing I would try would be to move
>> /etc/udev/rules.d/network_persistent.rules to root's home directory,
>> and reboot.  That way you should wind up with the wlp2s0f0 name
>> whether it's working or not, otherwise.
>> =-Jameson
> Fixed at: https://bbs.archlinux.org/viewtopic.php?id=159295
> -Josh

Fixed. I explain how the problem was fixed in post number 20. Here is the
link to the thread: https://bbs.archlinux.org/viewtopic.php?id=159295

More information about the arch-general mailing list