[arch-general] Upgrade finish in a "Kernel Panic - not syncing : no init found"

Dany De Bontridder dany118 at gmail.com
Fri Mar 22 18:00:02 EDT 2013


I reinstalled 2 weeks ago arch linux, because a pacman -Syu broke everything.

Today,  everything works fine and I decide to keep my PC up-to-date,
so I run pacman -Syu and I get a message when trying to boot

 *** Kernel Panic - not syncing : No init found. ***

Of course, because I saved the list of the packages before and after
this upgrade, (with pacman -Qe) I tried to downgrade, but it doesn't
work at all.

I still have the same message error, I checked and changed the
grub.cfg without no success : the rootfs is correct, the init is on
/dev/sda2 (a link to /usr/lib/systemd/systemd)

So I tried to append to vmlinuz line "init=3" "init=/sbin/init"
"init=/usr/lib/systemd/systemd" ... Without any success even when
downgrading the kernel version (from 3.8 to 3.7)

I can of course reinstall everything but I prefer to avoid that,
someone can help me please ??? I really don't understand what

Thanks in advance


More information about the arch-general mailing list