[arch-general] Upgrade finish in a "Kernel Panic - not syncing : no init found"

Dany De Bontridder dany118 at gmail.com
Sat Mar 23 11:23:24 EDT 2013


On Sat, Mar 23, 2013 at 6:17 AM, Jan Alexander Steffens
<jan.steffens at gmail.com> wrote:
> On Fri, Mar 22, 2013 at 11:00 PM, Dany De Bontridder <dany118 at gmail.com> wrote:
>> Hi,
>> I reinstalled 2 weeks ago arch linux, because a pacman -Syu broke everything.
>> Today,  everything works fine and I decide to keep my PC up-to-date,
>> so I run pacman -Syu and I get a message when trying to boot
>>  *** Kernel Panic - not syncing : No init found. ***
> Are you sure sda is the right device? When devices are added or
> removed from the system (even if it's just a USB dongle!), the
> numbering can change. This is why specifying the device directly
> (instead of through UUID or LABEL) is dangerous.
> Maybe the filesystem got corrupted. Chroot into your system from the
> install media and verify /usr/lib/systemd/systemd is present and
> executable.

I spent all the night on it, I've tried mkinicpio, check (ldd
/sbin/init), if executable, downgrade the kernel... Without success,
so I've reinstall everything and now it is working.

This failure is a complete mystery for me, it is the second time it
happens , finally I decide to ban the command "pacman -Syu" :-(

thank you for your help


More information about the arch-general mailing list