[arch-general] truecrypt, loop and /etc/modules-load.d/truecrypt.conf

Sean Greenslade sean at seangreenslade.com
Wed Oct 16 23:30:51 EDT 2013

On Mon, Oct 14, 2013 at 09:39:56AM -0700, John Davis wrote:
> Hello
> I used the wikipage to address the problem where loop module does not load.
> <snip>
>  # tee /etc/modules-load.d/truecrypt.conf <<< "loop"
> {{Note|As of udev 181-5, the loop device module is no longer auto-loaded,
> and the procedure described here is necessary.}}
> I am using a stock kernel.  I tried to use sudo to run truecrypt and it
> failed to setup a loop device.  I did a check of lsmod output and loop was
> not loaded after I made the truecrypt.conf change.
> After I modprobe loop by hand truecrypt would work and the encrypted drive
> would be mounted on /mnt/truecrypt1.  Is there something which needs to
> edited to the wiki page regarding truecrypt.conf?  It does not seem to
> work, and it seems that manually loading the module is required.
> -- 
> John F. Davis
> 6 Kandes Court
> Durham, NC 27713
> 919-888-8358

This change only affects the system on boot. modules-load.d is searched
upon boot and all modules listed are loaded. Have you tried rebooting
after creating the truecrypt.conf file?


More information about the arch-general mailing list