[arch-general] Error I trying update "pacman -Syu"

Maykel Franco maykeldebian at gmail.com
Tue Feb 25 16:09:11 EST 2014

2014-02-25 22:01 GMT+01:00 Karol Blazewicz <karol.blazewicz at gmail.com>:
> On Tue, Feb 25, 2014 at 9:56 PM, Bigby James <anoknusa at gmail.com> wrote:
>> On Tue, Feb 25, 2014 at 09:36:54PM +0100, Maykel Franco wrote:
>>> error: failed to prepare transaction (could not satisfy dependencies)
>>> :: haskell-haskeline: requires haskell-terminfo=
>> The package "haskell-haskeline" depends on an earlier version of the package
>> "haskell-terminfo" than the one currently available in [community]. I just tried
>> installing the former as a test, and got the same error you did. Chances are the
>> Trusted User responsible for haskell-haskeline hasn't yet updated the package
>> yet; I would suggest waiting a day or so and trying again or, if
>> haskell-haskeline isn't vitally important, uninstalling it and updating your
>> system. You could then try to reinstall the package later.
> [haskell-core] unofficial repo has haskell-haskeline which
> doesn't depend on haskell-terminfo.

Thanks. I removed the package haskell-haskeline and I try again sudo
pacman -Syu and it install haskell-terminfo- works
very well.

Thanks for all.

More information about the arch-general mailing list