[arch-general] no write access to gvfs-mount with certain applications

Eli Schwartz eschwartz93 at gmail.com
Sun Apr 26 18:52:46 UTC 2015

On Sun, Apr 26, 2015 at 8:31 AM, Sebastian Hempel <
sebastian at hempel-roeslau.de> wrote:

> Hi,
> I have a strange problem with gvfs mounts with the SMB/CIFS backend.
> Both packages are in the latest version 1.24.1-1.
> The smb shares are mounted with nautilus. The neccessary credentials are
> stored in the gnome-keyring. I can open / read and write files with
> LibreOffice and gedit. There is also no problem when accessing /
> creating files with the terminal and vi.
> But when I try to open a library with calibre the application tells me,
> that the database is read only. The access rights of the library files
> are all rwx and i can create files in the directory with for example
> touch or gedit.
> As fare as i can remember the (write) access with calibre worked before
> the update of the latest gnome version.
> Does anybody has suggestions how to solve this problem?

Official FAQ on using calibre with a NAS:

tl;dr -- don't.
calibre has never supported networked libraries, and although some people
have gotten it working, there is no particular reason -- it seems to work
sometimes, and sometimes not. Often people come to the support forums
complaining that what once worked, stopped working "for no reason

Your situation is not even slightly uncommon. My usual recommendation is,
if it is really important to have a networked copy, use rsync to mirror
your calibre library on your networked filesystem.

That being said, you can always try. :)
One thread that discusses the issue:
Problems include inconsistent support for file locking and hardlinks (file
operations are atomic).

Perhaps you will hit upon the magic combination.

 -- Eli Schwartz

More information about the arch-general mailing list