[aur-general] xfce4-pulseaudio-plugin unused shared libraries [done right]

NicoHood archlinux at nicohood.de
Mon Dec 5 16:15:34 UTC 2016

I tied ./configure LDFLAGS="-Wl,--as-needed" as suggested here:

The website covers the issue really good, however the fix does not seem
to work. Does this has to do something with the way arch runs make?

I also found those two posts on the ML:

It looks to me that this is still not fixed for arch nor upstream!?

The generated makefile contains:
LDFLAGS = -Wl,-O1,--sort-common,--as-needed,-z,relro

Even if I use it does still not work and give the warnings:
LDFLAGS = -Wl,--as-needed

Also something that might be of interest:
LIBNOTIFY_LIBS = -lnotify -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0
LIBXFCE4PANEL_LIBS = -lxfce4panel-2.0 -lgtk-3 -lgdk-3 -lpangocairo-1.0
-lpango-1.0 -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0
-lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lxfce4util

You can clearly see that all not required libs are listed there.

The x11 LD flags are also empty (by default). It does not help to change

I have no idea what else I could do. Any idea?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.archlinux.org/pipermail/aur-general/attachments/20161205/83bef3fe/attachment.asc>

More information about the aur-general mailing list