[aur-general] Why were my packages gtkwrite, gtkwrite-git, and gtkate deleted from AUR? (Tinu Weber)

John Briggs johneb47 at optusnet.com.au
Tue Sep 14 10:01:15 UTC 2021

On Tue, Sep 14, 2021 at 07:15:13AM +0000, zoorat via aur-general wrote:
> Hi Tinu,
> In the last mail, I tried to explain the reasons behind my deletion request message,
> where I should have sent this one. sorry.
> 1. when I tried to build with default, it failed.
> 2. I changed "gtksourceview2" to "gtksourceview3" and "gtksourceview4", build failed.


Today I downloaded the git repository for gtkwrite.
I followed the instructions in the README.md and compiled and generated gtkedit.
I inspected my include directory for the gtksourceview* directories and found that I had
both gtksourceview-3 and gtksourceview-4 installed. I suspected that I also could have
installed gtksourceview-5 from AUR if I had wanted.
As per the README.md file:
  $ make clean
  $ make with=-DWGTKSOURCEVIEW-4
and generated the gtkwrite executable.
I did not install the program because I was not familiar with the PKGBUILD file.

Because this package has been withdrawn I do not know how this will build against the PKGBUILD
file. I suspect PKGBUILD will need to be modified.


More information about the aur-general mailing list